`
mars914
  • 浏览: 429806 次
  • 性别: Icon_minigender_1
  • 来自: 北京
社区版块
存档分类
最新评论

Rightmost Digit

阅读更多

Problem Description

Given a positive integer N, you should output the most right digit of N^N. 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2

3

4 

Sample Output

7

6

Hint

 

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.

In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

可以发现一个规律:
当   n = 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 27 28 29 30 31 ...
rdigit = 1 4 7 6 5 6 3 6 9   0   1   6  3   6   5   6   7   4  9  0  1   4   7   6   5   6   3   6  9   0    ...
所以是以20为周期的规律。
得到这个规律,算法就变得很easy
#include<iostream>
using namespace std;
int main()
{
    int  rdigit[20] = {0,1,4,7,6,5,6,3,6,9,0,1,6,3,6,5,6,7,4,9};
    int n;
    cin>>n;
    int res[n];
    for(int i=0;i<n;i++)
    {
        int temp;
        cin>>temp;
        res[i]=rdigit[temp%20];
    }    
    for(int i=0;i<n;i++)
    {
        cout<<res[i]<<endl;
    }
    system("pause");
    return 0;
}    
 
分享到:
评论
1 楼 mars914 2012-04-13  
是指求n^n最后那位的那题?
这个可以化简的啊~~~
(a*b)%n=((a%n)*(b%n))%n
所以呢~
完全可以乘一次n,再求一次10的余数。然后对余数进行下一次的次方操作~
若n太大,则可用二进制优化,将n看作是二进制,例如8=1000
然后,n^8=(n^4)^2,这样算一次n^4就等于算了两次n^4了~
附上代码~
#include<stdio.h>
#include<stdlib.h>

int rightD(int n)
{
int ans=1;
int a=n,b=n;
a%=10;
while(b)
{
if(b%2==1)
{
ans*=a;
ans%=10;
}
b/=2;
a*=a;
a%=10;
}
return ans;
}
int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
printf("%d\n",rightD(n));
}
return 0;
}

相关推荐

Global site tag (gtag.js) - Google Analytics